Arquivo

Textos com Etiquetas ‘Postfix’

Combatendo SPAM com o Postgrey

3, novembro, 2010 Sem comentários

Opa,

Ultimamente notei no servidor de e-mail que o número de mensagens SPAM não paravam de crescer, resolvi então procurar uma solução de greylist (“espera”) para adicionar ao Postfix. Depois da implantação desse recurso obtive uma redução de cerca de 40% no número de SPAM recebido pelo servidor, seguem abaixo os passos utilizados em um OpenSuSE 10.3.

OBS.: Vale lembrar que após a ativação desse recurso as mensagens deverão sofrer um atraso na entrega, portanto use por sua conta e risco!

Instale o postgrey com o comando abaixo:

# zypper install postgrey

Ajuste o número em segundos da “espera” e coloque o serviço para executar no modo TCP:

# vim /etc/sysconfig/postgrey

POSTGREY_CONN_OPTIONS="--inet=127.0.0.1:60000"
POSTGREY_EXTRA_OPTIONS="--auto-whitelist-clients --delay=120"

Inicie o serviço:

# /etc/init.d/postgrey start

Edite o arquivo main.cf do Postfix para que o serviço seja utilizado, ajustando a variável smtpd_recipient_restrictions:

# vim /etc/postfix/main.cf

smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access hash:/etc/postfix/client_access, reject_unauth_destination, check_policy_service inet:127.0.0.1:60000, reject_rbl_client sbl-xbl.spamhaus.org, reject_rbl_client dnsbl.sorbs.net, reject_rbl_client bl.spamcop.net, reject_rbl_client combined.rbl.msrbl.net, permit

Pronto, agora basta salvar o arquivo e reiniciar o serviço para que a “espera” comece a funcionar:

# /etc/init.d/postfix restart

Não esqueça de ativar o serviço do postgrey na inicialização do sistema:

# chkconfig postgrey on

Abraço!

Fonte: http://www.howtoforge.net/spam-control-for-postfix

Categories: Linux Tags: , , , ,

Postfix: “while performing the HELO handshake”

10, fevereiro, 2010 Sem comentários

Opa,

Recentemente acessei um servidor antigo que não estava conseguindo enviar mensagens para diversos servidores na Internet retornando uma mensagem parecida com essa abaixo:

"lost connection with <a href="http://servidor.email.com/" target="_blank">servidor.email.com</a>[xxx.xxx.xxx.xxx] while performing the HELO handshake"

Após algumas pesquisas pela Internet descobri que esse problema poderia estar relacionado com o DNS, mais precisamente a variável myhostname do Postfix estava configurada para um endereço incorreto, após ajustar essa variável para o fqdn correto o erro não ocorreu mais e tudo voltou ao normal!

Fonte: http://www.iredmail.org/forum/topic48-errors-from-smtp.html

Categories: Linux Tags: , ,